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การสรางและดูแลเว็บดวย  Macromedia 
Dreamweaver  MX  

• HTML ภาษาพื้นฐาน 

HTML ยอมาจากคําวา Hypertext Markup Language เปนภาษาหลักที่ใชในการแสดงผลบนเว็บ

บราวเซอรในอินเทอรเน็ต ภาษา HTML แบงออกเปน 2 สวน คือ สวนที่เปนขอความทัว่ๆ ไป และสวน

ที่เปนคําสั่งทีใ่ชในการกําหนดรูปแบบของขอความที่แสดง  ซึ่งเราเรียกวา แท็ก (Tag) โดยคําสั่งของ 

HTML จะอยูในเครื่องหมาย < และ >  

<คําสั่ง>  ขอความ  </คําสั่ง> 

<TITLE> MY HOMEPAGE <TITLE> 

 

• โครงสราง HTML พื้นฐาน  

โครงสรางของภาษา HTML แบงออกไดเปน 4 สวนหลัก ดังนี้ 

<HTML>  

  <HEAD> 

   <TITLE> หัวขอเว็บเพจ <TITLE> 

  </HEAD> 

  <BODY> 

   สวนที่เปนเนื้อหา 

  </BODY> 

 </HTML> 

<HTML>… </HTML> เปนคําสั่งแรกที่ตองมีในภาษา HTML ซึ่งบงบอกวานี่คือภาษา HTML โดย

จะอยูที่จดุเริ่มตนของเอกสารและทายเอกสารในแตละแฟม 

<HEAD> … </HEAD> เปนสวนกําหนดรายละเอียดหัวขอเรื่อง ภายในจะมีคาํสั่งยอยอีกหนึ่งคําสัง่  

คือ <TITLE> … </TITLE> โดยใชชื่อหวัเรื่องของเว็บเพจ ซึ่งจะไปปรากฏอยูบน Title bar ของ

บราวเซอร 

<BODY> … </BODY> สวนนี้เปนสวนของเนื้อหาเว็บเพจของเรา  ไมวาจะเปนขอความ  รูปภาพ  

ตารางเสียง  และการเชื่อมตอไปยงัยังเอกสารอื่นๆ ที่จะแสดงผลที่เว็บบราวเซอร 
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• ความสามารถของ Macromedia Dreamweaver 

เปนโปรแกรมทีใ่ชงานไดงาย คลายกับโปรแกรม FrontPage, HomeSite, HotDog …  ผูใชสามารถ

ออกแบบองคประกอบตางๆ (เรียกวา Object)  ของหนาเว็บเพจไดเอง เพียงแคลากสวนตางๆ เขามา

ประกอบกัน โดยไมจาํเปนตองมีความรูในเรื่องของภาษา HTML (แตหากผูใชมีความรูเก่ียวกับภาษา 

HTML ก็จะเปนประโยชนในเขาใจหลักการทํางาน  การสราง รวมถึงการแกไขไดอยางละเอยีด)  

1. สนับสนุนการทาํงานแบบ WYSIWYG (What You See Is What You Get) คือ เราสรางอะไร 

บนหนาจอ Dreamweaver  ก็จะปรากฏผลแบบเดียวกันที่เวบ็เพจ ทําใหงายตอการใชงาน 

2. มีเครื่องมือชวยในการสรางรูปแบบหนาจอ และมีความยดืหยุนในการใชงานสูง 

3. สนับสนุนภาษาสคริปตตางๆ ทัง้ฝงไคลเอ็นต  และเซริฟเวอร เชน Java, ASP, PHP, CGI, 

VBscript 

4. มีเครื่องมือในการอัพโหลด (Upload) หนาเว็บเพจไปที่เครื่องเพ่ือทําการเผยแพร 

5. รองรับมัลติมีเดยี เชน เสียง กราฟก 

6. มีความสามารถทําการติดตอกับฐานขอมูล เพ่ือความสะดวกในการเขียนแอพพลิเคชั่นบน

เว็บไซต  

• เริ่มตนใชงาน Macromedia Dreamweaver 

 หลังจากที่ตดิตัง้โปรแกรม Dreamweaver MX เรียบรอยแลว สามารถเรยีกใชงานไดดังนี ้

1. คลิกที่ปุม Start 

2. All Program > Macromedia 

3. เลือก Macromedia Dreamweaver MX จะปรากฏหนาแรกใหเราเลือกหนาตางการทํางาน 

โดยจะมี 2 รูปแบบ คือ หนาตางการทํางานของโปรแกรม Dreamweaver MX  หรือจะใช

หนาตางการทาํงานแบบ Dreamweaver 4 
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• แนะนําการใชเครื่องมือใน Macromedia Dreamweaver MX  
 

 

• แถบคาํส่ัง (Menu bar)  

เปนแถบทีใ่ชเก็บคําสั่งทั้งหมดของโปรแกรม 

 

• แถบเครื่องมือ (Tool bar)  

เปนแถบทีร่วบรวมปุมคําสั่งที่ใชงายบอย 

 

• แถบสถานะ (Status bar) 

 

• สวนของ Properties (Properties Inspector) 

แตละ Object ที่เรานํามาใชสรางหนาเว็บเพจจะมคีุณสมบตัติางๆ ที่เราสามารถปรับแตงได 
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• สวน Panel Group  

เปนสวนที่เพ่ิมข้ึนมาเพื่อใหสามารถใชในการตดิตอกับฐานขอมูลฝงเซิรฟเวอร เพ่ือใหงายในการสราง 

Application บน Internet 

 

• รายละเอียดของแทบ็ Insert (Insert Bar) 

เปนกลุมเครื่องมือองคประกอบตางๆ (Object) ที่จะนํามาสรางหนาเว็บเพจ มี 12 กลุม ดังนี้ 

แท็บ Common  

เปนสวนทีร่วบรวมกลุมเครื่องมอืที่ใชสรางองคประกอบตางๆ ของเว็บ เชนการแทรกภาพ การแทรก

ตาราง การกําหนดลิงค เปนตน 

  กําหนดลิงค                 กําหนดอีเมลลิงค      แทรกตาราง 

  แทรกรูปภาพ        แทรกFlash        แทรกวันที ่

  กําหนดลิงคในเว็บเพจเดียวกัน 

แท็บ Layout 

เปนสวนรวมเครื่องมือทีช่วยในการจัดองคประกอบของหนาเว็บเพจ 
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แท็บ Text  

เปนที่รวบรวมคาํสั่งเก่ียวกับการใชงานตัวอักษร 

แท็บ Table  

รวบรวมคําสั่งในการสรางตารางใหกับเว็บเพจ 

 

แท็บ Frames  

รวบรวมคําสั่งทีใ่ชในการแบงหนาเว็บเพจใหออกเปนสวนยอย 

 

แท็บ Forms 

 แทรกเครื่องทีใ่ชในการสรางแบบสอบถาม และตัวเลือกตางๆ 

 

แท็บ Templates 

ใชในการกําหนดรูปแบบใหกับเว็บเพจ 

 

 

แท็บ Characters  

เปนกลุมเครื่องมือที่ใชแทรกตวัอักษร และสญัลักษณพิเศษ 

 

  การแทรก Line Break    การแทรกที่วาง 

แท็บ Media  

ใชสําหรับแทรกไฟลวิดีโอ, ภาพเคลื่อนไหว, Flash, Java applet, ActiveX หรือ Plugin ในหนาเว็บ 
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  การแทรกไฟล Flash     การสรางปุมแบบ Flash    การสรางตัวอักษรแบบ Flash 

แท็บ Head 

เปนการแทรกคาํสั่งเสริมในหนาเว็บ เชน คียเวริด เพ่ือให Search Engine สามารถคนหาเว็บเราได 

 

แท็บ Script  

ใชในการแทรกภาษาสคริปตในเว็บ 

แท็บ Application 

เปนแท็บทีร่วบรวมคาํสั่งที่ใชสรางแอพพลิเคชั่นตดิตอกับฐานขอมูลผานเวบ็เซิรฟเวอร 

 

 

• หนาตางเว็บเพจ (Document Window) 

สําหรับหนาตางการทํางาน  Macromedia Dreamweaver MX สามารถเลอืกได 3 รูปแบบ 

 Show Code View เปนหนาตางที่แสดงเฉพาะ HTML ของเว็บเพจที่เรากําลงัทํางานอยู 
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 Show Code and Design Views เปนหนาตางที่แสดงทั้ง HTMLและหนาเวบ็เพจที่ออกแบบ 

 

 Show Design View  แสดงแตหนาเว็บเพจปกติไมแสดง HTML 

 

• ทําให Dreamweaver ใชภาษาไทยได 

ตองติดตั้งฟอนตภาษาไทย (thai addon) หลังติดตั้งเรยีบรอยแลวเมื่อเขามาที่โปรแกรม 

Dreamweaver ใหเลือกคําสั่ง Edit > Preferences และเลือก Fonts เพ่ือกําหนดภาษาและชุด

ตัวอักษร โดยในชอง Font Settings ใหเลือก THAI Windows-874 
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• เริ่มตนสรางเว็บไซต  
1. ไปที่เมนู Site >New Site 

2. เลือกแท็บ Advanced   

3. Site Name กําหนดชื่อใหกับเว็บไซต  

4. Local Root Folder คลิก  เลือกโฟลเดอรทีต่องการเก็บ เว็บไซต  
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การเริ่มตนสราง Site งาน ครั้งแรกโปรแกรมถามวา ตองการสรางไฟล cache สําหรับเว็บไซตหรือไม 

ไฟล cache ใชในการปรับไฟลตาง ๆ ในเว็บไซตใหเชื่อมโยงถูกตอง แมจะยายไฟลขามโฟลเดอร

ยอยก็ตาม หากไมตองการใหมีขอความนี้เตือนทุกครั้ง  ให Don’t ask again  

5. Dreamweaver จะแสดงโฟลเดอรที่เก็บไซตใหมในหนาตางแท็บ Site  

 

• การสรางโฟลเดอรใหมในเว็บไซต   

เลือก Files > New Folder จากเมนูของแท็บ Site หรือคลิกขวาที่โฟลเดอรที่เราเก็บเว็บไซตเลือก 

New Folder 
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• การสรางเว็บเพจใหมในโฟลเดอร  

เลือก File>New File จากแทบ็ Site หรือ คลิกขวาที่โฟลเดอรที่ตองการสรางหนาเว็บเพจใหม  เลือก 

New File 

 

 

 

 

• การกําหนดคุณสมบัติของหนาเว็บเพจ (Page Properties) 

กอนเริ่มตนสรางเว็บควรเริ่มกําหนดคุณสมบตัหิลักของหนาเว็บกอน  โดยการเลือกคําสั่ง Modify > 

Page Properties จากเมนูบาร หรือคลิกขวา เลือกคําสั่ง Page Properties  จะพบหนาตาง Page 

Properties  

รายละเอียดในหนาตาง Properties 
1. Title กําหนดหวัเรื่องของหนาเว็บ 

2. Background Image กําหนดภาพทีใ่ชเปนฉากหลังของหนาเว็บ 

3. Background กําหนดสีทีต่องการใหเปนพ้ืนหลังของหนาเว็บ 

4. Text กําหนดสตีัวอักษรปกต ิ

5. Links กําหนดสใีหกับตัวอักษรที่ทาํการ Links  

6. Visited Links กําหนดสีใหกับตัวอักษรที่เคยคลิก Links  

7. Links Links กําหนดสีใหกับตวัอักษรขณะคลกิ Links  

8. Active Links กําหนดสีใหกับ Links แบบตาง ๆ  

9. Left Margin กําหนดระยะขอบซายของหนาเวบ็ (ใชกับบราวเซอร Explorer) 

10. Top Margin กําหนดระยะขอบบนของหนาเว็บ (ใชกับบราวเซอร Explorer) 

11. Margin Width กําหนดระยะขอบซายของหนาเว็บ (ใชกับบราวเซอร Netscape) 

12. Margin Height กําหนดระยะขอบบนของหนาเว็บ (ใชกับบราวเซอร Netscape) 

13. Document Encoding กําหนดชดุตัวอักษร (ใหใช Thai Windows-874) 
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14. Tracing Image และ Image Transparency ใชกําหนดภาพที่ใชอางอิงหรือใชเปนเทม

เพลต 

 

• ขอความ (Text) 

สามารถพิมพขอความไดเหมือนการพิมพเอกสารใน MS Word และกําหนดคุณสมบตัติางๆ เชน 

รูปแบบขอความ, การจดัตาํแหนงขอความ (Alignment) 

 

• รูปภาพ (Image) 
1. เลือกรูปที่ตองการโดยกดปุม  (Image) หรือไปที่เมนู Insert> Image 

2. เลือกไฟลรูปภาพจากเครื่อง PC  

3. พิมพคําอธิบาย ในหัวขอ Alt ( ภาพที่นํามาแสดงบนเว็บเพจ บางครั้งไมสามารถ Load 

ภาพขึ้นมาแสดงได) 

 

• การเชื่อมโยง (Link)  
การเช่ือมโยงภายในเว็บเพจเดียวกัน 

1. กําหนดจดุ Anchor หรือจดุ Link ที่จะกระโดดไปในหนาเว็บเพจนั้น 

2. คลิกเมาสที่แถบ Common หรือเลือกจากเมนู Insert > Named Anchor 
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3. ตั้งชื่อจดุ Anchor แลวคลิกที่ปุม OK 

 

4. คลิกคลุมขอความทีต่องการกําหนดใหเชื่อมโยง กําหนดการเชื่อมโยง โดยการพิมพ # 

ตามดวยชื่อจุด Anchor 

 

กําหนดลกัษณะของเพจใหมที่เช่ือมโยง 

รูปแบบการแสดงผลบนเฟรมจากชอง Target ในแถบ Properties หรือเลอืกไดจากเมนู Modify> Link 

Target 

1. _blank ใหเปดเพจที่เชื่อมโยงในหนาตางใหมอีกหนาตาง 

2. _parent ใหเปดเพจที่เชื่อมโยง แสดงเพจหนาเดิม 

3. _self ใหเปดเพจที่เชื่อมโยง แสดงในเฟรมเดยีวกันกับที่มีขอความอยู 

4. _top ใหเปดเพจที่เชื่อมโยงขยายเตม็หนาจอ 

 

การเช่ือมโยงภายในเว็บไซตเดียวกัน 

1. คลิกเลือกขอความ หรือ รูปภาพ ที่จะกําหนดใหเชื่อมโยง  

2. กําหนดจดุเชื่อมโยงโดยคลิกที่ปุม จาก Properties ที่ชอง Link  

3. เลือกไฟลทีต่องการเชื่อมโยง 

 
การเช่ือมโยงเว็บไซตอื่น 

1. คลิกเลือกขอความ หรือ รูปภาพที่จะกําหนดใหเชื่อมโยง  

2. พิมพชื่อ เว็บไซต โดยใหพิมพ http:// นําหนาชื่อเว็บเพจทีเ่ราตองการเชื่อมโยง ทีช่อง Link 

จาก Properties เชน http://www.swu.ac.th  

 
การเช่ือมโยงดวยอีเมล 

1. เลือกขอความ หรืออีเมล ทีต่องการกําหนดใหเชื่อมโยงไปยังอีเมล  
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2. พิมพอีเมลแอดเดรสทีช่อง Link จาก Properties โดยพิมพคาํวา mailto: ตามดวยชื่ออีเมลที่

ตองการใหสง เชน mailto:suwimon@swu.ac.th 

 
การเช่ือมโยงดวย Map Link 

เปนการทําภาพในเว็บเพจ ที่ประกอบดวยพ้ืนที่ยอยทีถู่กกําหนดใหเชื่อมโยงกับขอมูล โดยสามารถคลิก

ที่สวนตาง ๆ ของภาพเพื่อเชื่อมโยงไปยังขอมูลทีแ่ตกตางกันได 

1. คลิกภาพที่จะสราง Map Link  

2. เลือกบริเวณทีต่องการ Link โดยใชออบเจ็กต จาก Properties 

3. กําหนดพื้นที่ของรูปภาพที่จะเชื่อมโยง โดยการคลิกเมาสคาง แลวลากใหเปนกรอบ 

4. เลือกไฟลทีต่องการเชื่อมโยง โดยคลิก  

• ตาราง (Table) 
 

1. คลิกเมาส ตําแหนงทีต่องการวางตาราง 

2. คลิกที่ปุม  เครื่องมือสรางตาราง Insert Table ในแถบ Object ปรากฏ กรอบทํางาน ดังนี้ 

  

กําหนดรายละเอียดของตาราง คอื  

• Rows จํานวนแถวของตาราง  

• Columns จํานวนคอลัมนของตาราง  

• Width ความกวางของตาราง กําหนดหนวยไดทั้งระบบ % และ Pixel  

• Border ความหนาของเสนขอบรอบตาราง  

• Cell Padding ระยะหางจากขอบขางในของเซลลเขามาในเซลล มีหนวยเปน pixel 

• Cell Spacing ความหนาของเสนคั่นระหวางเซลล  

การลบตาราง 

1. คลิกเลือกตารางทั้งตาราง 

2. กดปุม Delete  

การลบแถว, ลบคอลัมน 

1. คลิกเลือกแถวหรือคอลมันทีต่องการลบ 

2. กดปุมขวาของเมาส ปรากฏเมนูลัด 

3. เลือกคําสั่ง Delete Row หรือ Delete Column  
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การเพิ่มแถว 

1. นําเมาสไปคลิกในเซลลสุดทายของตาราง  

2. กดปุม Tab จะไดแถวใหมตอจากแถวสดุทายของตารางโดยอัตโนมตั ิ 

การแทรกแถว/คอลัมน 

1. คลิกเลือกแถวหรือคอลมันทีต่องการแทรก  

2. กดปุมขวาของเมาส ปรากฏเมนูลัด  

3. เลือกคําสั่ง Insert, Row หรือ Insert Column หรือ Insert Rows or Columns (กรณี

ตองการแทรกมากกวา 1)  

 

• การสรางเฟรมเซตในเว็บเพจ 
 
เฟรม คือ ลักษณะของการแบงพ้ืนที่หนาตางหลัก ของบราวเซอรออกเปนสวนยอย ๆ เพ่ือใชสําหรับ

แสดงเว็บเพจใหแตละสวนแยกจากกันอยางอิสระ  

วิธีการแบงเฟรม ไปที่ แถบ Frames คลิกเลือกรูปแบบเฟรมตามที่ไดออกแบบ 

 

กําหนดรายละเอียดหนาตาง Properties  

 

• Borders กําหนดใหแสดง (Yes) / ไมแสดง (No) ขอบลอมเฟรม (Default คือ Yes) 

• Border Width กําหนดความหนาของเฟรม ถาไมตองการแสดงขอบเฟรม กําหนดคานี้เปน 0 

• Border Color กําหนดสีของขอบเฟรม 

• Column (or Row) and Units กําหนดขนาดของคอลัมน หรือความสูงของเฟรม โดยใหเราระบุ

หนวยที่ใชในชอง Units  

• Pixels หนวย pixel แมนยําทีส่ดุ ในการกําหนดขนาด 

• Percent หนวยเปอรเซ็นตกับเฟรมอ่ืนในหนาตาง 

• Relative หนวยเปอรเซ็นตกับขนาดหนาตางบราวเซอร 



การสรางและดูแลเว็บดวย Macromedia Dreamweaver MX สุวิมล  คงศักด์ิตระกูล 

เอกสารประกอบการอบรมโครงการอบรมสําหรับผูดูแลเว็บหนวยงานของมหาวิทยาลัย   15

รายละเอียดแถบ Properties ของหนาเวบ็ในเฟรมยอย 

แถบ ของ Panel Group ดานขวามือของโปรแกรมจะมี เครื่องมือ Advanced Layout ? คลิกเลือกแถบเฟรม 

? คลิกสวนใดสวนหนึ่งของเฟรม  

 

ปรากฏรายละเอียด หนาตาง Properties ของหนาเว็บในเฟรมยอย 

  

Frame Name ตั้งชื่อที่ใชเรียกเฟรมยอย ซึ่งตองอางถึงชื่อเฟรม เม่ือมีการเชื่อมโยงกับ

เฟรมใหใชตัวอักขระเล็กในการตั้งชื่อ 

Src ใหกําหนดชื่อและตําแหนงเก็บไฟลเว็บเพจทีจ่ะถูกนํามาใชในเฟรม 

Borders กําหนดใหแสดง (Yes) / ไมแสดง (No) ขอบลอมเฟรมยอย  

(Default คือ Yes) 

Scroll กําหนดใหแสดง (Yes) / ไมแสดง (No) แถบเลื่อน (Scroll bar) ในเฟรม

ยอยAutoใหแสดงแถบเลื่อนเฉพาะ เม่ือมีขอมูลเกินกวาที่จะแสดงไดบน

หนาจอ (Default คือ Auto) 

No Resize สั่งใหแสดงขอบเฟรมยอย หากไมตองการใหมีการใชเมาส  ปรับขนาดเฟรม

ใหเช็คถูกหนาขอความนี ้

Border Color กําหนดสีขอบเฟรม 

Margin Width 

Margin Height 

กําหนดระยะหางระหวางหนาเวบ็ในเฟรมยอยกับขอบเฟรม 

โดย Margin Width จะวัดจากดานซายของเฟรม  

Margin Height จะวดัจากดานบนของเฟรม 

การแทรกเว็บเพจลงในเฟรม 

1. เปดหนาตางเฟรมโดยเลือกคําสั่ง Window -->Others --> Frames หรือ กด Shift + F2 

2. Click เลือกสวนของเฟรมทีต่องการจะแทรกเว็บเพจ 

3. Click ที่  เพ่ือเลือกไฟลเว็บเพจที่ตองการแทรก 

4. เลือกไฟลทีต่องการแทรก ปรากฏหนาเว็บเพจในเฟรมทีถู่กเลือกไว 



การสรางและดูแลเว็บดวย Macromedia Dreamweaver MX สุวิมล  คงศักด์ิตระกูล 

เอกสารประกอบการอบรมโครงการอบรมสําหรับผูดูแลเว็บหนวยงานของมหาวิทยาลัย   16

การบันทึกเฟรมยอย 

1.  เลือกคําสั่ง File>Save All หรอืกดคีย <Ctrl+Shift+S> คือการบันทึกทุกไฟลที่ประกอบเปนหนา

เว็บเฟรม 

2. โปรแกรมจะถามใหบันทึกหนาตอไป ซึ่งจะปรากฏเสนประ รอบ ๆ เฟรมยอย โดยจะบันทึกจากดาน 

ขวาลาง? ซายลาง ? ขวาบน ? ซายบน จนครบทุกเฟรมยอม (ควรตองชื่อใหเหมาะกับตําแหนง

เฟรม) 

หากมีการแกไขหรือเปลี่ยนแปลงทุกครั้งตอง ใชคําสั่งบันทกึ File > Save All Frames 

การเช่ือมโยงหนาเวบ็ในเฟรม 

1. ลากเมาสเลือกขอความทีต่องกําหนดเปน Link 

2. Click mouse  ปุม เพ่ือเลือกไฟลที่จะเชื่อมโยงดวยในแถบ Properties  

3. เลือกไฟลทีต่องการเชื่อมโยงดวยแลว Click ปุม selete 

4. กําหนดรูปแบบการแสดงผลบนเฟรมจากชอง Target ในแถบ Properties ตัวอยางเราเลือก Main 

Frame คือ เฟรมที่อยูดานขาวมือ 

• _blank เปดเพจใหมข้ึนมา 

• _parent แสดงเพจหนาเดิม โดยจะลบเฟรมออก 

• _self แสดงในเฟรมเดียวกันกับที่มีขอความอยู 

• _top ขยายเต็มหนาจอ 

รูปแบบที่เพิ่มมาจากการเชื่อมโยงปกติ คือ 
• mainFrame แสดงเพจใหมในหนา mainframe 

• topFrame แสดงเพจใหมในหนา topFrame 

• leftFrame แสดงเพจใหมในหนา leftFrame 

5. เซฟแลวตรวจสอบผานบราวเซอร เม่ือ Click ที ่Link หนาเว็บเพจที่สามารถเชื่อมโยงได จะถูก

แสดงในสวนเฟรมที่กําหนดไว 

• การใช Cascading Style Sheet 

เปดหนาตาง CSS Styles โดยเลือก Window > CSS Styles 
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คลิกปุม  หรือเลือกคําสั่ง Text > CSS > Edit Style Sheet คลิกปุม New 

 

จะมีรูปแบบใหเลือก 3 รูปแบบ ดังนี้ 

• Make Custom Style เปนการสรางแบบกําหนดชื่อใหม(เรยีกวา Class) 

• Redefine HTML Tag เปนการระบุคําสั่ง HTML ที่จะเปลี่ยนรูปแบบใหเปนสไตลใหม 

• Use Css Selector เปนการกําหนดสไตลให Link ในแตละแบบ 

Define In คือการกําหนดสไตลตามรูปแบบตอไปนี้ 

• New Style Sheet File กําหนดใหสรางสไตลข้ึนมาใหม 

• This Document Only กําหนดใหใชไฟลเอกสารนี้เทานั้น 

คลิกปุม OK 

 

กําหนดรูปแบบที่ตองการใหกับสไตลชที 

• การนําสไตลชีทมาใชงาน 

คลิกปุม  เลือกไฟลสไตลชีทที่เก็บไว แลวคลิกปุม OK 
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โปรแกรมจะทําการสรางโคดให ดังนี้ <link href="/style_sheet/testcss.css" rel="stylesheet" 

type="text/css"> หมายถึงการที่เราเรียกใชไฟลสไตลชีทที่สรางข้ึน 

• การตรวจสอบ Link ในเว็บไซต 

ในระหวางการสรางเว็บไซต อาจมีการกําหนด Link ใหเชือ่มโยงไปยังไฟลตางๆ แตบางครั้งเราอาจ

ไมไดสรางไฟลน้ันข้ึนมา ทําใหเว็บของเราเกิดปญหา Link เสียหรือ Broken Link เราสามารถตรวจสอบ

ปญหานี้ไดโดย 

2. เลือกโฟลเดอรที่ตองการตรวจสอบ Broken Link 

3. เลือก File > Check Links 

 

4. Dreamweaver จะตรวจสอบทกุ Link ในโฟลเดอรและไฟลตาง และสรุปใหเราทราบ โดยแบง

แสดงเปน 3 กลุม ดังนี ้

• Show Broken Link  แสดง Link แบบ Relative ที่เสยี 

• Show External Links แสดง Link  แบบ Absolute ที่เชื่อมโยงไปนอกเว็บไซต 

• Show Orphaned Files แสดงไฟลที่ไมไดเชือ่มโยงกับที่ใดเลย 
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• การกําหนดขอมูลเก่ียวกับเครื่องเซิรฟเวอร 

กอนที่เราจะทําการอัพโหลดขอมูลไปยังเครื่องเว็บเซิรฟเวอรไดน้ัน เราจําเปนตองทราบ ชือ่เครื่องเว็บ

เซิรฟเวอร, Account Name และ Password กอนจึงจะสามารถนําขอมูลข้ึนไปเก็บยังเครื่องเว็บ

เซิรฟเวอรได 

1. เลือก Site > Edit Sites 

2. เลือกเว็บไซต กดปุม Edit 

3. เลือก Remote Info 

4. เลือก FTP 

• FTP HOST พิมพชื่อเครื่องเซิรฟเวอร  >> www.swu.ac.th 

• Host Directory กําหนด directory ของเครื่อง (สวนใหญเราไมตองระบ)ุ 

• Login พิมพชื่อ Account >> www 

• Password พิมพรหสัผาน 

• Check เลือก Use Passive FTP สําหรับการเชื่อมตอกังเครื่องเว็บเซิรฟเวอรที่มีการติดตั้ง

ระบบ Firewall  
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• การอัพโหลดไฟลจากเครื่องเราสูเครื่องเซิรฟเวอร 
1. เลือกไฟลและโฟลเดอรทีต่องการอัพโหลด 

2. คลิกปุม Put Files   เพ่ือนําไฟลเขาเครื่องเซิรฟเวอร หรือ คลกิปุม Get Files  เพ่ือนําไฟล

จากเครื่องเซิรฟเวอรมายังเครือ่ง PC ที่เราทํางาน 

 

 


